use strict;
my $str = 'random text H326 H243+H546+H677 H234+H333 some other random texts
X123 X234+X567 X567+X890+X654';
my $regex = qr/\b[HPGX]\d{3}(?:\+[HPGX]\d{3})*\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}