package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[HPGX]\d{3}(?:\+[HPGX]\d{3})*\b`)
var str = `random text H326 H243+H546+H677 H234+H333 some other random texts
X123 X234+X567 X567+X890+X654`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}