using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s+j[^a-zA-Z]*e[^a-zA-Z]*t\b";
string input = @"hi jet
hi jetto
hello j(e)t(t)o
hey jellyt
ji j***e***t";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}