re = /(\w+)\s+j[^a-zA-Z]*e[^a-zA-Z]*t\b/i
str = 'hi jet
hi jetto
hello j(e)t(t)o
hey jellyt
ji j***e***t'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end