import re
regex = re.compile(r"(\w+)\s+j[^a-zA-Z]*e[^a-zA-Z]*t\b", flags=re.IGNORECASE)
test_str = ("hi jet\n"
"hi jetto\n"
"hello j(e)t(t)o\n"
"hey jellyt\n"
"ji j***e***t")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")