$re = '/(\w+)\s+j[^a-zA-Z]*e[^a-zA-Z]*t\b/i';
$str = 'hi jet
hi jetto
hello j(e)t(t)o
hey jellyt
ji j***e***t';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);