package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\w+)\s+j[^a-zA-Z]*e[^a-zA-Z]*t\b`)
var str = `hi jet
hi jetto
hello j(e)t(t)o
hey jellyt
ji j***e***t`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}