import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\s+j[^a-zA-Z]*e[^a-zA-Z]*t\\b";
final String string = "hi jet\n"
+ "hi jetto\n"
+ "hello j(e)t(t)o\n"
+ "hey jellyt\n"
+ "ji j***e***t";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}