use strict;
my $str = '**Input**
Ndd12
12Ndd12
Ndd 12
Nav G45up
Mr Nave12en ';
my $regex = qr/^\d+|(?<=\w)\d+(?![\d\s])|(?<=\s)\s+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";