import re
regex = re.compile(r"^\d+|(?<=\w)\d+(?![\d\s])|(?<=\s)\s+", flags=re.MULTILINE)
test_str = ("**Input**\n"
"Ndd12\n"
"12Ndd12\n"
"Ndd 12\n"
"Nav G45up\n"
"Mr Nave12en ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)