re = /^\d+|(?<=\w)\d+(?![\d\s])|(?<=\s)\s+/m
str = '**Input**
Ndd12
12Ndd12
Ndd 12
Nav G45up
Mr Nave12en '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result