import Foundation
let pattern = #"^\d+|(?<=\w)\d+(?![\d\s])|(?<=\s)\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
**Input**
Ndd12
12Ndd12
Ndd 12
Nav G45up
Mr Nave12en
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)