$re = '/^\d+|(?<=\w)\d+(?![\d\s])|(?<=\s)\s+/m';
$str = '**Input**
Ndd12
12Ndd12
Ndd 12
Nav G45up
Mr Nave12en ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;