import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":\\s+(\\\")";
final String string = " \"data\": [\n"
+ " ^ {\n"
+ " \"ServerName\": \"server.name\",\n"
+ "... ^\n"
+ "...\n"
+ " \"LastUpdated\": \"sexta-feira, 23 de outubro de 2020 06:09:09\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}