// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#":\s+(\")"#).unwrap();
let string = " \"data\": [
^ {
\"ServerName\": \"server.name\",
... ^
...
\"LastUpdated\": \"sexta-feira, 23 de outubro de 2020 06:09:09\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}