#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^(0[1-9]|1[0-9]|2[0-9]|3[01])(0[1-9]|1[0-2])[0-9]{2}-[0-9]{4}$"
Local $sString = "http://www.example.com" & @CRLF & _
"file://www.example.png" & @CRLF & _
"file://www.example.com" & @CRLF & _
"ftp://image.jpg" & @CRLF & _
"ftp:host..jpgcom" & @CRLF & _
"http://www.imgur.com/image2.gif" & @CRLF & _
"oops I made a mistake.jpg" & @CRLF & _
"htp://notamatch.html.jpg" & @CRLF & _
"http://website.com.jpg" & @CRLF & _
"this isn't even valid...jpg" & @CRLF & _
"jpg.jpg.com" & @CRLF & _
"file.com" & @CRLF & _
"file://.com" & @CRLF & _
"file://a.com" & @CRLF & _
"http://something.co.uk" & @CRLF & _
"http://something.cosuk" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")