using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0[1-9]|1[0-9]|2[0-9]|3[01])(0[1-9]|1[0-2])[0-9]{2}-[0-9]{4}$";
string input = @"http://www.example.com
file://www.example.png
file://www.example.com
ftp://image.jpg
ftp:host..jpgcom
http://www.imgur.com/image2.gif
oops I made a mistake.jpg
htp://notamatch.html.jpg
http://website.com.jpg
this isn't even valid...jpg
jpg.jpg.com
file.com
file://.com
file://a.com
http://something.co.uk
http://something.cosuk
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}