package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(0[1-9]|1[0-9]|2[0-9]|3[01])(0[1-9]|1[0-2])[0-9]{2}-[0-9]{4}$`)
var str = `http://www.example.com
file://www.example.png
file://www.example.com
ftp://image.jpg
ftp:host..jpgcom
http://www.imgur.com/image2.gif
oops I made a mistake.jpg
htp://notamatch.html.jpg
http://website.com.jpg
this isn't even valid...jpg
jpg.jpg.com
file.com
file://.com
file://a.com
http://something.co.uk
http://something.cosuk
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}