# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(0[1-9]|1[0-9]|2[0-9]|3[01])(0[1-9]|1[0-2])[0-9]{2}-[0-9]{4}$"
test_str = ("http://www.example.com\n"
"file://www.example.png\n"
"file://www.example.com\n"
"ftp://image.jpg\n"
"ftp:host..jpgcom\n"
"http://www.imgur.com/image2.gif\n"
"oops I made a mistake.jpg\n"
"htp://notamatch.html.jpg\n"
"http://website.com.jpg\n"
"this isn't even valid...jpg\n"
"jpg.jpg.com\n"
"file.com\n"
"file://.com\n"
"file://a.com\n"
"http://something.co.uk\n"
"http://something.cosuk\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.