import Foundation
let pattern = #"^(0[1-9]|1[0-9]|2[0-9]|3[01])(0[1-9]|1[0-2])[0-9]{2}-[0-9]{4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
http://www.example.com
file://www.example.png
file://www.example.com
ftp://image.jpg
ftp:host..jpgcom
http://www.imgur.com/image2.gif
oops I made a mistake.jpg
htp://notamatch.html.jpg
http://website.com.jpg
this isn't even valid...jpg
jpg.jpg.com
file.com
file://.com
file://a.com
http://something.co.uk
http://something.cosuk
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)