use strict;
my $str = 'http://www.example.com
file://www.example.png
file://www.example.com
ftp://image.jpg
ftp:host..jpgcom
http://www.imgur.com/image2.gif
oops I made a mistake.jpg
htp://notamatch.html.jpg
http://website.com.jpg
this isn\'t even valid...jpg
jpg.jpg.com
file.com
file://.com
file://a.com
http://something.co.uk
http://something.cosuk
';
my $regex = qr/^(0[1-9]|1[0-9]|2[0-9]|3[01])(0[1-9]|1[0-2])[0-9]{2}-[0-9]{4}$/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}