import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0[1-9]|1[0-9]|2[0-9]|3[01])(0[1-9]|1[0-2])[0-9]{2}-[0-9]{4}$";
final String string = "http://www.example.com\n"
+ "file://www.example.png\n"
+ "file://www.example.com\n"
+ "ftp://image.jpg\n"
+ "ftp:host..jpgcom\n"
+ "http://www.imgur.com/image2.gif\n"
+ "oops I made a mistake.jpg\n"
+ "htp://notamatch.html.jpg\n"
+ "http://website.com.jpg\n"
+ "this isn't even valid...jpg\n"
+ "jpg.jpg.com\n"
+ "file.com\n"
+ "file://.com\n"
+ "file://a.com\n"
+ "http://something.co.uk\n"
+ "http://something.cosuk\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}