const regex = /^(0[1-9]|1[0-9]|2[0-9]|3[01])(0[1-9]|1[0-2])[0-9]{2}-[0-9]{4}$/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0[1-9]|1[0-9]|2[0-9]|3[01])(0[1-9]|1[0-2])[0-9]{2}-[0-9]{4}$', 'ig')
const str = `http://www.example.com
file://www.example.png
file://www.example.com
ftp://image.jpg
ftp:host..jpgcom
http://www.imgur.com/image2.gif
oops I made a mistake.jpg
htp://notamatch.html.jpg
http://website.com.jpg
this isn't even valid...jpg
jpg.jpg.com
file.com
file://.com
file://a.com
http://something.co.uk
http://something.cosuk
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}