# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\W?\d*?\W*?(?<area>\d{3})\W*?(?<group1>\d{3})\W*?(?<group2>\d{4})\W*?$/Phone Number: (\{area})-\{group1}-\{group2}/gm;t' <<< "6109410561
(484) 844.0221
484-433-8115
484 433 7972
610.715.6728
+16109410561
"