import Foundation
let pattern = #"^\W?\d*?\W*?(?<area>\d{3})\W*?(?<group1>\d{3})\W*?(?<group2>\d{4})\W*?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
6109410561
(484) 844.0221
484-433-8115
484 433 7972
610.715.6728
+16109410561
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Phone Number: (\{area})-\{group1}-\{group2}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)