package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\W?\d*?\W*?(?<area>\d{3})\W*?(?<group1>\d{3})\W*?(?<group2>\d{4})\W*?$`)
var str = `6109410561
(484) 844.0221
484-433-8115
484 433 7972
610.715.6728
+16109410561
`
var substitution = "Phone Number: (\{area})-\{group1}-\{group2}"
fmt.Println(re.ReplaceAllString(str, substitution))
}