const regex = /[A-Z]:.*\.\w+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]:.*\\.\\w+', 'g')
const str = `"msqlsum81pv 0 0 25 25 25 2 -sn D:\\\\workdir\\\\PV 81\\\\config\\\\sum81pv.pwf -C 5000"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);