using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{[^}]+?(?:,?img:([^,}]+))?(?:,?alt:([^,}]+),)?(?:,?ht:(\d+))?(?:,?wd:(\d+))?(?:,?align:(\w+))?}}";
string substitution = @"<img src=""www.abc.com/media/images/$1"" alt=""$2"" width=""$3"" height=""$4"" align=""$5"">";
string input = @"juices vegetables including {{smartpro=img:hippo-1.jpg,alt:Hippocrates,ht:217,wd:247,align:left}} wheatgrass, leafy greens, parsley, aloe vera & other herbs";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}