const regex = new RegExp('{{[^}]+?(?:,?img:([^,}]+))?(?:,?alt:([^,}]+),)?(?:,?ht:(\\d+))?(?:,?wd:(\\d+))?(?:,?align:(\\w+))?}}', 'ig')
const str = `juices vegetables including {{smartpro=img:hippo-1.jpg,alt:Hippocrates,ht:217,wd:247,align:left}} wheatgrass, leafy greens, parsley, aloe vera & other herbs`;
const subst = `<img src="www.abc.com/media/images/$1" alt="$2" width="$3" height="$4" align="$5">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);