re = /{{[^}]+?(?:,?img:([^,}]+))?(?:,?alt:([^,}]+),)?(?:,?ht:(\d+))?(?:,?wd:(\d+))?(?:,?align:(\w+))?}}/i
str = 'juices vegetables including {{smartpro=img:hippo-1.jpg,alt:Hippocrates,ht:217,wd:247,align:left}} wheatgrass, leafy greens, parsley, aloe vera & other herbs'
subst = '<img src="www.abc.com/media/images/$1" alt="$2" width="$3" height="$4" align="$5">'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result