package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i){{[^}]+?(?:,?img:([^,}]+))?(?:,?alt:([^,}]+),)?(?:,?ht:(\d+))?(?:,?wd:(\d+))?(?:,?align:(\w+))?}}`)
var str = `juices vegetables including {{smartpro=img:hippo-1.jpg,alt:Hippocrates,ht:217,wd:247,align:left}} wheatgrass, leafy greens, parsley, aloe vera & other herbs`
var substitution = "<img src="www.abc.com/media/images/$1" alt="$2" width="$3" height="$4" align="$5">"
fmt.Println(re.ReplaceAllString(str, substitution))
}