// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i){{[^}]+?(?:,?img:([^,}]+))?(?:,?alt:([^,}]+),)?(?:,?ht:(\d+))?(?:,?wd:(\d+))?(?:,?align:(\w+))?}}").unwrap();
let string = "juices vegetables including {{smartpro=img:hippo-1.jpg,alt:Hippocrates,ht:217,wd:247,align:left}} wheatgrass, leafy greens, parsley, aloe vera & other herbs";
let substitution = "<img src=\"www.abc.com/media/images/$1\" alt=\"$2\" width=\"$3\" height=\"$4\" align=\"$5\">";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}