import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{[^\\}]+?(?:,?img:([^,\\}]+))?(?:,?alt:([^,\\}]+),)?(?:,?ht:(\\d+))?(?:,?wd:(\\d+))?(?:,?align:(\\w+))?\\}\\}";
final String string = "juices vegetables including {{smartpro=img:hippo-1.jpg,alt:Hippocrates,ht:217,wd:247,align:left}} wheatgrass, leafy greens, parsley, aloe vera & other herbs";
final String subst = "<img src=\"www.abc.com/media/images/$1\" alt=\"$2\" width=\"$3\" height=\"$4\" align=\"$5\">";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}