# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/%.(?=[^;]*?\slimit\b)/'$0'/gmi;t' <<< "select * from tbl1 where id = %d and name = %s limit %d,%d;
select * from tbl1 where id = %d and name = %s limit %d;"