const regex = /%.(?=[^;]*?\slimit\b)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('%.(?=[^;]*?\\slimit\\b)', 'gmi')
const str = `select * from tbl1 where id = %d and name = %s limit %d,%d;
select * from tbl1 where id = %d and name = %s limit %d;`;
const subst = `'$0'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);