use strict;
my $str = 'select * from tbl1 where id = %d and name = %s limit %d,%d;
select * from tbl1 where id = %d and name = %s limit %d;';
my $regex = qr/%.(?=[^;]*?\slimit\b)/mip;
my $subst = '\'$0\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";