import re
regex = re.compile(r"%.(?=[^;]*?\slimit\b)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("select * from tbl1 where id = %d and name = %s limit %d,%d;\n"
"select * from tbl1 where id = %d and name = %s limit %d;")
subst = "'$0'"
result = regex.sub(subst, test_str)
if result:
print(result)