import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "%.(?=[^;]*?\\slimit\\b)";
final String string = "select * from tbl1 where id = %d and name = %s limit %d,%d;\n"
+ "select * from tbl1 where id = %d and name = %s limit %d;";
final String subst = "'$0'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}