using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%.(?=[^;]*?\slimit\b)";
string substitution = @"'$0'";
string input = @"select * from tbl1 where id = %d and name = %s limit %d,%d;
select * from tbl1 where id = %d and name = %s limit %d;";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}