re = /%.(?=[^;]*?\slimit\b)/mi
str = 'select * from tbl1 where id = %d and name = %s limit %d,%d;
select * from tbl1 where id = %d and name = %s limit %d;'
subst = '\'$0\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result