$re = '/%.(?=[^;]*?\slimit\b)/mi';
$str = 'select * from tbl1 where id = %d and name = %s limit %d,%d;
select * from tbl1 where id = %d and name = %s limit %d;';
$subst = "'$0'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;