# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\w)(?:http:\/\/www\.example\.com)?\/(\S+?)\.pdf\b/\/wp-content\/uploads\/old\/$1.pdf/ig;t' <<< "some containing string http://www.example.com/subfolder/name.pdf or /subfolder/name.pdf
<a href=\"/pdf/subdir/name.pdf\">clickhere</a><a href=\"/pdf/subdir/name.pdf\">2nd PDF</a>"