import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\w)(?:http://www\\.example\\.com)?/(\\S+?)\\.pdf\\b";
final String string = "some containing string http://www.example.com/subfolder/name.pdf or /subfolder/name.pdf\n\n"
+ "<a href=\"/pdf/subdir/name.pdf\">clickhere</a><a href=\"/pdf/subdir/name.pdf\">2nd PDF</a>";
final String subst = "/wp-content/uploads/old/$1.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}