$re = '@(?<!\w)(?:http://www\.example\.com)?/(\S+?)\.pdf\b@i';
$str = 'some containing string http://www.example.com/subfolder/name.pdf or /subfolder/name.pdf
<a href="/pdf/subdir/name.pdf">clickhere</a><a href="/pdf/subdir/name.pdf">2nd PDF</a>';
$subst = "/wp-content/uploads/old/$1.pdf";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;