# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/test(?!(?:(?!<_strong>).)*<_\/strong>)/<_strong>$0<_\/strong>/g;t' <<< "This is a test, and test word appears two times
This is a test, and <_strong>test word<_/strong> appears two times"