import re
regex = re.compile(r"test(?!(?:(?!<_strong>).)*<_/strong>)")
test_str = ("This is a test, and test word appears two times\n\n"
"This is a test, and <_strong>test word<_/strong> appears two times")
subst = "<_strong>$0<_/strong>"
result = regex.sub(subst, test_str)
if result:
print(result)