import Foundation
let pattern = #"test(?!(?:(?!<_strong>).)*<_/strong>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This is a test, and test word appears two times
This is a test, and <_strong>test word<_/strong> appears two times
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<_strong>$0<_/strong>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)