using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test(?!(?:(?!<_strong>).)*<_/strong>)";
string substitution = @"<_strong>$0<_/strong>";
string input = @"This is a test, and test word appears two times
This is a test, and <_strong>test word<_/strong> appears two times";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}