re = /test(?!(?:(?!<_strong>).)*<_\/strong>)/
str = 'This is a test, and test word appears two times
This is a test, and <_strong>test word<_/strong> appears two times'
subst = '<_strong>$0<_/strong>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result