# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?),\s*/$1\n#/gm;t' <<< "software.cisco.com , Added by IT, ZZ 6584"